Author Topic: Editing chrome policies files  (Read 875 times)

rickhamilton620

  • Newbie
  • *
  • Posts: 4
    • View Profile
Editing chrome policies files
« on: February 12, 2015, 07:20:56 AM »
I'm trying to modify our ubermix install so that Chrome doesn't present the "sign into chrome" option to users.

I'm following the instructions here (http://www.chromium.org/administrators/linux-quick-start) to create the preferences file. I created the folder structure under /opt/etc/, created the file, and placed the file in the folder while booted in Generic mode. However it won't "take" for whatever reason. I rebooted and still get the "sign into chrome" message.

Is it because of the unique file system of ubermix or am I missing something elsewhere?

Thanks!

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 286
    • View Profile
Re: Editing chrome policies files
« Reply #1 on: March 22, 2015, 02:02:52 PM »
Seems to be working for me. What does your policy file look like?

Juan Pucheu

  • Full Member
  • ***
  • Posts: 78
    • View Profile
Re: Editing chrome policies files
« Reply #2 on: May 27, 2015, 01:19:44 PM »
It's also works for me.
Boot into "generic" mode, so all the changes will be saved.
In a terminal, do this:
1) sudo mkdir /etc/opt/chrome/policies/managed
2) sudo mkdir /etc/opt/chrome/policies/recommended
3) sudo chmod -w /etc/opt/chrome/policies/managed
4)cd into the managed directory, then
5) touch test_policy.json
then, edit the file
sudo nano test_policy.json
my json file looks like this:
{
   "HomepageIsNewTabPage": false,
   "ShowHomeButton": true,
   "SafeBrowsingEnabled": true,
   "PasswordManagerEnabled": true,
   "HomepageLocation": "http://www.esaa.edu.ar"
}
Pay attention to the json format, don't forget the "," separators.
In chrome, type chrome://policy/, and it will show all your changes.
The homepage setting on chrome is weird, they want you to login at google first....