Author Topic: Release notes old. Minimum reqs not listed. and more  (Read 3191 times)

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Release notes old. Minimum reqs not listed. and more
« on: August 26, 2014, 11:53:39 PM »
Your Release Notes are very obviously not up to date!

http://wiki.ubermix.org/page/Ubermix_Changelog

1.32 being the latest notes for v1.x yet the Downloads page is for v1.4!

Although where is 1.5? Ubuntu 12.04.5 has come out, which should have signalled a point update from yourself. You promise to keep v1.x updated until May 2015! And your Blog is even more out of date! Or at least has different selections of info...


On the Downloads/Installation page you really should have a clear, easy to find Minimum Requirements section! I am considering installing on some old, donated laptops at a school in Nepal but your use of Unity makes me think it just isn't going to run very well!!

On that note how about updating the page on Alternative Desktops? Giving some indication whether they even exist after v1.05 would be helpful!!


I don't know the full range of specifications of the computers here but for example, one I looked at this morning had a 1.7GHz Celeron processor and 512MB of RAM. Obviously this will struggle with Unity! Should I consider 2.1L or 1.4? Or are these things too ancient to even consider this distro??

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #1 on: August 27, 2014, 12:01:52 AM »
Also you really should include Dates in your Release Notes, not just Version Numbers! It really helps give people an idea of how active a project actually is! Nothing else can tell you the time difference between say 1.0.4 and 1.0.5!!


PS - Your anti-BOT measures are really over the top!!! Why do you feel quite so much is needed??
PPS Assuming everybody knows about America for the BOT measures is totally sucky too!!

Juan Pucheu

  • Full Member
  • ***
  • Posts: 78
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #2 on: August 27, 2014, 03:11:53 PM »
It's a non profit project. You can register in the wiki, and update all the outdated info

urkomasse

  • Full Member
  • ***
  • Posts: 81
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #3 on: August 27, 2014, 08:38:26 PM »
We will happily refund you your Ubermix licensing costs :)

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #4 on: August 28, 2014, 08:51:56 AM »
I'll just look into my crystal ball and get all the information I obviously don't have!! There was a really beeping stupid, wise-crack comment to make!!!!


Although, to be fair, my post did kinda deserve it! It's what happens when I go to track down information which isn't available when I have a cracking headache from being in a 12ft squared room filled with screaming children!!


Maybe I can get a more reasonable reply on the only real question in my posts, as some things are still appealing to this distro over the official Edubuntu....

Will it run nicely with any of the included DEs on a laptop such as a 1.7GHz Celeron with 512MB RAM. If so would V2.x-L or V1.x be more recommended?

Regards and apologies for the aggressive posting. :)

Juan Pucheu

  • Full Member
  • ***
  • Posts: 78
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #5 on: August 29, 2014, 01:01:20 PM »
512 Mb is just too little.
1.8x, the last one before the new 2.0x update, will work

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #6 on: August 30, 2014, 01:43:41 AM »
I expected this to be the case. Although Edubuntu claims to work on 512MB I hear the same (although just about usable if you install LXDE.)

Where is 1.8? I can only see 1.4 mentioned.

http://ubermix.org/files.html

And as I said I thought it looked like the (Vers-x.y.z) y part of the release name appeared to match Unbuntu Point Releases, meaning a 1.5 should hopefully be in the pipeline...

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #7 on: August 30, 2014, 01:17:41 PM »
Why not provide a torrent link like most other distros? With an average of 12 hours power outage a day and an average download speed of <10kbs this is going to be a pain to download even with wget!! At least torrents pick up from where they left off automatically when connection is resumed, rather than having to be manually kicked off each time!

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #8 on: September 01, 2014, 06:15:37 PM »
W00t finally managed to finish downloading it! :)

dd'd to a USB key and there is no Live mode?? Any reason why not? Or has it maybe been added since v2.x??

It's going to be even harder for me to persuade schools I might volunteer at to consider using it on some of their ageing hardware if I can't even demonstrate it first! (No I'm not willing to lose partition space of my personal laptop!) Plus I really would have liked to test drive it on the ageing hardware, to see  how smoothly it runs, before actually considering installing it!! :(

urkomasse

  • Full Member
  • ***
  • Posts: 81
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #9 on: September 02, 2014, 04:57:01 PM »
If you read the information about the partition layout, and all the features about quick-restore, you would realize that this is not a "normal" Linux distribution. You obviously have a lot of experience with Linux, and certain expectations on how it should work that are simply not true about Ubermix.
The quick-restore feature is in my opinion the main feature of Ubermix, and it is the feature that makes Ubermix require a custom install procedure, and makes it impossible to test as a Live CD.



I'd recommend using VirtualBox or other virtualization software to test it out.

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #10 on: September 03, 2014, 08:54:45 AM »
If you need to demonstrate, why not just use the VM? It's technically possible to install it dual boot, but less than trivial to get it installed due to the aforementioned partition layout.

kazakore

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Release notes old. Minimum reqs not listed. and more
« Reply #11 on: September 04, 2014, 10:05:55 AM »
If you read the information about the partition layout, and all the features about quick-restore, you would realize that this is not a "normal" Linux distribution. You obviously have a lot of experience with Linux, and certain expectations on how it should work that are simply not true about Ubermix.
The quick-restore feature is in my opinion the main feature of Ubermix, and it is the feature that makes Ubermix require a custom install procedure, and makes it impossible to test as a Live CD.

Fair enough, although I don't see exactly why. I guess maybe because a new installer would have to be made to get around the way it works and that is a lot more real coding than putting together a distro! But if the Restore partition was a disk image, then it could very easily be imaged from a Live USB just as much as any OS could be as far as I can tell, but from what I've read you've gone more down the keeping a log of changes and reverting route... But even then it should be fairly trivial, at the Live USB stage there are no reversions steps that need to be changed! (I'm not talking about having any kind of Persistence or anything.) I've noticed the F5 option lets you create a new USB install key from the current system though. I like that.

Also agree the quick restore is very important. That plus the inclusion of some things that go against the Ubuntu philosophy and thus will never be included as standard is why I decided to try this rather than Edubuntu.


Quote
I'd recommend using VirtualBox or other virtualization software to test it out.

Well as it took three days to download the .img downloading the version for VB as well really wasn't an option! I was just looking at ways to get img converted to a format VirtualBox will open when we lost power the other day, then no internet at all yesterday and most of today. Almost through my emails and things now and really it's past my bedtime!! I also leave here for about three weeks tomorrow morning... But I will look into VMing it (and if you can link a useful guide for working with the img file it would be appreciated.)


Bad news: (note I went for v1.4 in the end)
I installed it on my first PC, a Dell Latitude E6400, a fair bit faster than the machines I mentioned but it was in Polish and locked out with nobody aware of the password so seemed a good candidate.
First problem: Wireless doesn't work! This means that I can't run any updates etc. No access to the router via Ethernet! (There are some messages at Boot but I've been too bleary-eyed to read them fully tonight.)
If I run the Simple Updates then almost all of the Help file seems incorrect! There is no Launcher! There is no Dash where described! I couldn't even find a way to launch Terminal at all (not even Alt+F2), only way to get command line was going to a different TTY.
Reinstalled without the Simple Updates and at least I can get to Terminal through Accessories now... Only confirmed I have no wireless and this no network. Double-checked all BIOS settings and tried hardware switch in both positions.

Also: Am I blind or is there no GCompris included? This is a package I have just installed on all the Windows PCs for a bit of play time after more serious lessons, seemed quite popular for teaching (although UberMix is targeted at slightly older I thought covered the whole range.) If I had wifi I would definitely add this and reimage (probably after removing FreeCiv, which is FAR to large and wouldn't be appreciated at all out here I think, and possibly other bits...)


I will probably try and download v2.x at some point too, so I have options if I do more work where people are open to my suggestions. V2.x for 2GB and up, anything below v1.x?? Or would you even go with v2.x on a 1GB machine? Seems a bit close to the minimum really required...