Author Topic: Login screen in Ubermix?  (Read 2249 times)

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Login screen in Ubermix?
« on: May 03, 2014, 03:02:58 PM »
We have (we think) successfully joined an Ubermix laptop to our Active Directory domain.  But, I cannot seem to find any way to have a login screen show up when the machine starts up.  It just starts to the regular Launchpad.  How can we get a login screen to show up so that we can test if AD users can log in?

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: Login screen in Ubermix?
« Reply #1 on: May 04, 2014, 10:54:31 AM »
You'll need to remove the autologin entries from /etc/lightdm/lightdm.conf . Can do by opening a terminal and 'sudo gedit /etc/lightdm/lightdm.conf'

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #2 on: May 04, 2014, 12:03:57 PM »
Thanks! Will try it and let you know.  Really appreciate the response.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #3 on: May 05, 2014, 01:44:19 PM »
Weellll. I tried it.
Removed both autologin entries from the lightdm.conf (autologin-user=user and autologin-user-timeout=0)and added "greeter-show-manual-login=true". 
Saved. Restarted, and at startup it just goes into some strange mode where the screen is black/grey/black/grey... with the white mouse pointer the only thing showing, an endless loop. 
Have to restore it to get back in.
Also tried removing another entry - user-session=une-efl and got the same behavior.

I tried to attach a screen shot of what is displayed at startup after restore, but attachments do not seem to work.

I am sure I am missing something and I am a total newbie in Linux but want so badly to use Ubermix at the school where I work.






jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: Login screen in Ubermix?
« Reply #4 on: May 05, 2014, 01:55:19 PM »
OK, go to System Settings:User Accounts or, if you don't see that, open a terminal and type 'gnome-control-center user-accounts'. Turn off Automatic Login there and see if it works better.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #5 on: May 06, 2014, 05:23:26 AM »
Should I also remove it from lightdm.conf?

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #6 on: May 06, 2014, 05:37:00 AM »
no user accounts in system settings,
so i used the terminal and got the response: WARNING**:Could not find settings panel "user-accounts": Unknown error

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: Login screen in Ubermix?
« Reply #7 on: May 06, 2014, 05:18:31 PM »
Seems like you might have installed the simple updates, which makes that tool invisible. Open a terminal and 'sudo rm -rf /usr/local/share/applications/gnome-user-accounts-panel.desktop' then look for 'User Accounts' in System Settings

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #8 on: May 07, 2014, 06:08:25 AM »
Unfortunately, it is still not there.  Would you recommend that I go back to a fresh install?  Will I need to install centrify again?

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: Login screen in Ubermix?
« Reply #9 on: May 07, 2014, 06:22:37 AM »
Try the terminal command from a few entries ago first, and if you still see an error, then yes, I would reinstall using option 1 (ie do not install simple updates). Then unset auto login in system settings and install centrify.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Login screen in Ubermix?
« Reply #10 on: May 07, 2014, 10:56:15 AM »
Thank you so much for your help and patience!  Finally got it to work and am so excited!