Author Topic: sound only works for one user account  (Read 3292 times)

gtjr92

  • Newbie
  • *
  • Posts: 2
    • View Profile
sound only works for one user account
« on: April 24, 2014, 09:50:33 AM »
I set up separate local user for ubermix. The sound works fine for the default account, but not for any other user.
It only shows dummy output for the sound device on any other user. Even other admin users.
I have the latest version of ubermix and this is a new install.

thanks


Marker

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #1 on: April 24, 2014, 01:18:25 PM »
I'm not sure if this will help, but it's worth a check. We had trouble when trying to do some screencasts and found that we had to:
go to the Settings, then in Sound  go to the Input Tab. Raise the Input volume slider to about 50%. In Kazam, be sure Audio Source 1 is on (checked) and then choose "Built-in Analog Stereo".

Again, this may not be of any help. Sorry if it's not.

Good Luck,

/\/\ ark

gtjr92

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: sound only works for one user account
« Reply #2 on: April 24, 2014, 07:38:09 PM »
No that didn't help. Any one else have a suggestion?

urkomasse

  • Full Member
  • ***
  • Posts: 81
    • View Profile
Re: sound only works for one user account
« Reply #3 on: April 24, 2014, 09:11:48 PM »
Check which groups your new user belongs to.
You can do it by opening a terminal, and running the command "groups".


As root, you can also run it for a particular user:
sudo -i (to become root)
groups user (to check which groups the default user belongs to)
groups yournewusername (to compare with the above)

If those lists of groups don't match, you can do:
adduser yournewusername nameofthegroup


Maybe this will help? Pay attention to groups related to sound.

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: sound only works for one user account
« Reply #4 on: May 04, 2014, 11:27:03 AM »
You can just type 'id user' at a terminal prompt to see which groups they are in. "audio" and "video" are the groups you want to add other users to.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #5 on: May 12, 2014, 09:57:16 AM »
Having the same problem on my Sony laptop.  "User" has sound, but those who log in with network credentials (we are joined to an AD domain) do not have sound.  In sound settings for those users, the sound hardware just shows dummy output, whereas for "user" it has "built in audio analog stereo"  Is there a way to make sound available to all users?  I will be wanting to install Ubermix in our school computer labs and sound will be necessary for network users.

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: sound only works for one user account
« Reply #6 on: May 14, 2014, 02:13:15 PM »
Edit /etc/security/group.conf and add the following line at the end:

*;*;*;Al0000-2400;adm,cdrom,floppy,sudo,audio,dip,video,plugdev,bluetooth,scanner,lpadmin,netdev,sambashare

Then all users will automagically be members of the listed local groups on login.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #7 on: May 16, 2014, 07:47:10 AM »
I see why you are the "hero member" jnetman1!  Will try this when I get back to the laptop.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #8 on: May 20, 2014, 09:48:53 AM »
OK, tried this:   /etc/security/group.conf
as root and got "Permission denied"

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #9 on: May 20, 2014, 09:58:46 AM »
OH, and when I type "Edit" I get
No command 'Edit' found, did you mean:
command 'edit' from package 'mime-support' (main)

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #10 on: May 22, 2014, 12:46:17 PM »
I assume that I don't actually have to type "Edit" but I tried when it would not give me permission on the  /etc/security/group.conf.  What am I doing wrong?  I am logged in as user then sudo -i to get to root... Type in  /etc/security/group.conf and get Permission Denied

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: sound only works for one user account
« Reply #11 on: May 23, 2014, 02:46:52 PM »
Sorry, too many assumptions in my response. Probably the easiest way for you to edit a system file would be to open a terminal (ctrl-alt-t) and type:

sudo gedit /etc/security/group.conf

jnetman1

  • Administrator
  • Hero Member
  • *****
  • Posts: 285
    • View Profile
Re: sound only works for one user account
« Reply #12 on: May 23, 2014, 03:54:21 PM »
Just realized I missed a step. After the added line above, do the following (from a terminal window):

sudo gedit /usr/share/pam-configs/my_groups

copy and paste from below and save the file:

Code: [Select]
Name: activate /etc/security/group.conf
Default: yes
Priority: 900
Auth-Type: Primary
Auth:
        required        pam_group.so use_first_pass

sudo pam-auth-update

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #13 on: May 28, 2014, 02:08:20 PM »
I am apparently still missing something.  Sorry to beat this topic with a stick but I really want to make it work!  I am learning with each step and so appreciate the help!

OK, I was able to get into the group.conf file.  I went all the way to the end and pasted in the line
*;*;*;Al0000-2400;adm,cdrom,floppy,sudo,audio,dip,video,plugdev,bluetooth,scanner,lpadmin,netdev,sambashare
then saved.  I actually tried pasting it at the very end and also before where it said:# End of group.conf file (at different times, testing it each time)

Either way, when I logged out and logged back in as a domain user, the sound still did not work and the sound settings listed Dummy Output as the only device. I did follow the other instructions:

sudo gedit /usr/share/pam-configs/my_groups

copy and paste from below and save the file:

Code: [Select]
Name: activate /etc/security/group.conf
Default: yes
Priority: 900
Auth-Type: Primary
Auth:
        required        pam_group.so use_first_pass

sudo pam-auth-update

So, I guess I am doing something wrong still.

ginlodge

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: sound only works for one user account
« Reply #14 on: June 06, 2014, 03:14:23 PM »
Hello,

I have gone through all of the steps very carefully and still do not have any sound for network users who log in.  Would it be possible to list the steps one more time?  Or could you look at what I have done and tell me what I am doing wrong?:

Log in as user
Open a terminal
Sudo -i to operate as root
type
sudo gedit /etc/security/group.conf
(There is a lot of text in that screen explaining how to modify it)
Added the following line at the end of that screen
*;*;*;Al0000-2400;adm,cdrom,floppy,sudo,audio,dip,video,plugdev,bluetooth,scanner,lpadmin,netdev,sambashare
save and exit that screen
back in the terminal
sudo gedit /usr/share/pam-configs/my_groups

copy and paste from below and save the file:

Name: activate /etc/security/group.conf
Default: yes
Priority: 900
Auth-Type: Primary
Auth:
        required        pam_group.so use_first_pass

Save and exit
Back in terminal type
sudo pam-auth-update

Exit everything
log out
restart computer
log back in as domain user
still no sound
:(